Welche Plugins braucht man ...

Escape NextGen Gallery

Es gab Zeiten, in denen die NextGen Gallery eine echte Alternative zur Galeriefunktion von WordPress war. Das hat sich mittlerweile geändert.

Ältere Installationen, die dieses Plugin verwenden, können nicht ganz einfach auf die wordpresseigene Galerie umsteigen, weil die Bilder z. B. in einem eigenen gallery-Verzeichnis gespeichert werden.

Escape NextGen Gallery wandelt vorhandene Galerien um. Das funktioniert aber nur mit jeweils einem [nggallery] Shortcode pro Seite. Und wenn eine WordPress-Galerie und ein [nggallery] Shortcode auf einer Seite sind, werden mitunter Bilder aus der vorhandenen Wordpress-Galerie in die neu konvertierte übernommen. Nachdem aber das Rauslöschen der überzähligen Bilder schneller geht als die Fehlersuche, sollte man hier den pragmatischen Ansatz wählen.


Media Library Assistant

Media Library AssistantZugegeben, das Plugin kann echt viel und ich nutze vermutlich nur ganz wenig.

Eine Funktion, die sehr zeitsparend ist, nennt sich "IPTC/EXIF Mapping". Damit kann man JPG's bereits im Betriebssystem (Windows) mit einem Titel versehen und diesen anschließend automatisch in Titel, Alternativtext und Beschreibung der WordPress-Medien-Datei einfügen.

Weiters werden zusätzliche Filter und Suchfunktionen in die Mediathek eingebaut.

Mediathek ohne Media Library Assistant

Mediathek mit Media Library Assistant


 

qTranslate-X

Dies ist eine Weiterentwicklung von qTranslate, das aber zum heutigen Stand am 26.1.2014 zuletzt upgedated wurde. Nachdem zuletzt Probleme mit qTranslate aufgetreten sind, bin ich auf mqTranslate umgestiegen. Und nachdem das nicht mehr weiterenwickelt wird, bin ich jetzt bei qTranslate-X gelandet. Der Umstieg zwischen den Versionen verlief übrigens jeweils ohne Probleme.

Mit diesem Plugin können Seiten mehrsprachig gestaltet werden.


Resize Images before upload

Ist eigentlich schon selbsterklärend. Dafdurch können Fotos direkt vom Speichermedium raufgeladen werden, ohne, dass man befürchten muss, eine 5 MB Datei in die Seite einzubauen.


Sucuri Security

Mit diesem feinen Plugin kann einerseits geprüft werden, ob man sogenannten Brute-Force-Angriffen (Passwort erraten) ausgesetzt ist und andererseits die WordPressinstallation sicherer gemacht werden.

Siehe dazu auch die Artikel Sicherheit gegen Hackerangriffe bei WordPress und Das Salz in der Suppe für die WordPress-Sicherheit.


WP-Mail-SMTP

Sollte die standardmäßig am Server eingestellte Absendeadresse nicht den eigenen Vorstellungen entsprechen, kann dies mit diesem Plugin geändert werden.

Zudem kann ausgewählt werden, ob E-Mails mit SMTP oder der PHP mail()-Funktion gesendet werden.

Mit dem "Broken Link Checker" die Links in einer WordPress-Seite aktuell halten

Broken Link Checker - AllgemeinJetzt bin ich gerade wieder auf einer Hotelseite auf einen Link gestoßen, der ins Leere zeigte ... dumm wenn es sich gerade dabei um die Allgemeinen Geschäftsbedingungen handelt.

Zum Glück gibt es ein Plugin, das ich verwende, das genau dieses Problem verhindert.

Man kann sich unter dem Reiter Allgemein eine E-Mail Benachrichtigung schicken lassen, wenn ein defekter Link entdeckt wurde.

Im "Suchen Sie nach Links in" Reiter lasse ich veröffentlichte Beiträge, Kommentare und Seiten durchsuchen.

Unter Welche Links überprüfen sind "HTML Links" und "HTML Bilder" ausgewählt.

Und bei Protokoll & Schnittstellen ist "Standard HTTP" eingestellt.

Bei Erweitert kann man einstellen, ob auch Redakteure die ungültigen Links sehen können.

Alles in Allem ein sehr nützliches Plugin.